1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sony WM-EX654 Skips Between Sides Randomly

Discussion in 'Tech talk' started by Zydiz, Feb 14, 2018.

  1. Zydiz

    Zydiz New Member

    Messages:
    5
    Trophy Points:
    1
    Location:
    Istanbul, Turkey
    Hello i just got this device, replaced the belt (the belt is the right size) but when i press play i hear the music for a second or so and the i hear one long beep then two small beeps and it plays the other side, does the same thibg over and over, pressing stop, play doesn't make any diffrence, they switch the sides ehen i press them. How can i solve this issue?

    (Btw this device's circuit is similar/same with lots of the WM-EX series so if a fix works for you it may work for me too)
     
  2. Zydiz

    Zydiz New Member

    Messages:
    5
    Trophy Points:
    1
    Location:
    Istanbul, Turkey
    And the stop function doesn't work. It strangely switches to the other side of the tape
     
  3. Command8

    Command8 Active Member S2G Supporter

    Messages:
    198
    Trophy Points:
    28
    Location:
    Milano
    Have you tried pressing and holding to stop your machine. Walkmans from the 90's had alot of machines that have 2 functions; pressing stop switches the sides, but pressing and holding stops your machine.
     
  4. Zydiz

    Zydiz New Member

    Messages:
    5
    Trophy Points:
    1
    Location:
    Istanbul, Turkey
    I will try it but in the manual it just says press stop to stop, i contacted a repairman he said it was about the band, if it didn't strech enough the mechanism inside wont work properly he said, i dont know.
     

Share This Page